Thank you!

CLOSE

I’m upgrading NexRemote to a new version from the Celestron website. I see the message “License may be corrupt” and/or “You do not have the appropriate license for this software” stopping me from upgrading. What can I do?