Thank you!

CLOSE

I’m trying to install TheSkyX First Light in Windows XP. It stops installation and displays “TheSkyX requires a newer version of OpenGL to run.” What do I do next?