Will TheSky software run on Windows Vista?

TheSky was supplied with Celestron telescopes sold before 2009. It will run in Vista 32, but will display a registry error when the program launches and may have other problems. It won’t work at all with Vista 64. 


For a more current version that runs without problems on Vista, please visit Software Bisque and download TheSky X.

 

Updated 12/16/13